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1. Introduction  

With the List & Label Designer, you create or edit different print templates for 
printing information that originates either from a database or a nother data source. In 
the Designer, you then have all the data at your disposal and can prepare it for 
printing in different ways.  

The Designer always uses the data that is passed from the program, in other words, 
the application handles the process of se lecting and compiling the data.  

Thus, "the Designer" is not a self-contained application, but rather is incorporated in 
List & Label as an inherent part of an application.  

The Designer ð the print, preview and export dialog ð is normally started via a me nu 
item (e.g. Configuration > Print or Output > Print).  

1.1 General  
The different print templates are referred to as "Projects". Along with the actual print 
information, a project also contains, above all, layout specifications suc h as page size 
and orientation, fonts, colors, frames, circles, lines, graphics etc. The List & Label 
Designer can handle three different types of projects: Lists, labels and cards.  

The individual elements of such a project are called "objects". For exampl e, a project 
can contain text objects, picture objects and a report container.  

The required objects are normally selected in the object list, created on the 
workspace with the mouse and then given the respective contents and layout 
propert ies.  

The List & Label Designer provides different types of objects which you can position 
freely in the workspace and change the size as required.  

Á Text and contents of variables  

Á Lines 

Á Rectangles 

Á Circles and ellipses 

Á Picture object  

Á Barcode 

Á Report container  or Table object (depending on the application): The Report 

container can hold tables, charts, crosstabs and Gantt charts.  

Á Charts: Schematic view of data.  

Á Crosstabs: For presenting data in multiple dimensions.  

Á Formatted text: For changing the formatting wi thin a line. 

Á Form elements: For entering data in the preview and PDF format.  



Screen 

11 

Á Data Graphic: For simple visualization of data as a bar or symbol.  

Á Gauge: For visualization of data as gauge or scale. 

Á HTML content: For embedding HTML pages.  

Á PDF: For embedding PDF documents.  

Á OLE container. For linking OLE documents (e.g. Word, Excel).  

Á Form templates are placed in the background of the workspace as a template so 

that other objects can be aligned to them.  

1.2 Screen 
The Designer interface consists of a workspace and different tool windows.  

Á The objects are placed in the workspace. You change the shape and size of the 

workspace via Project > Page Setup . 

Á You can select the viewing mode by means of the tabs at the workspace 

borders: Layout, Layout Preview, Preview.  

Á The status bar with the current mouse position, the current operation and the 

position/size.  

Á You add objects by means of the 'Objects' toolbar.The object list shows the 

inserted objects.  

Á Tool windows for the available variables and fields (Variables -/Field-List), the 

elements of the report container (Report Structure), the different display layers 

(Layers) and the properties of the selected object or projec t (Properties). 
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2. Getting Started  

This chapter describes how to create a simple list based on the combit List & Label 
Sample Application.  

If you use List & Label as part of an application, you can usually start the Designer via 
a menu item or similar. The f unctionality can differ slightly from the description 
below.  

2.1 The Sample Application  
The Designer is not available as a self-contained application, but rather is 
incorporated in List & Label as an inherent part of an application. For this reason, the 
Sample Application is used to create the examples.  

You will find the Sample Application in the program menu of the List & Label 
installation. Alternatively, you can download it as part of the combit List & Label 
program installation at  www.combit.net/en/reporting/ . 

You can then start the Designer via the "Design" menu item. Start the print, preview 
and export dialog via the "Print" menu item. Under options, you will find various 
configuration settings such as the language of the program interface or the number 
of sample files.  

 

Figure 2.1: Sample Application  

http://www.combit.net/en/reporting/
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2.2 The Sample Database  
The List & Label Sample Application contains a Microsoft Access Database for a 
fictitious company called "Northwind" with sample data for a food wholesaler.  

It is a relational database meaning that the data is dis tributed across several tables. 
Each table contains data elements that are related to one another. For instance, one 
table contains the product data. Another contains the product categories. A table's 
columns are referred to as fields (product name), and t he rows of a table as data 
records. 

 
Figure 2.2: Structure of the Microsoft Northwind sample database  

2.3 Produce a Simple Report  
For a first simple report, you will produce a product list in alphabetical order with a 
report title and a company logo.  

1. Start the combit List & Label Sample Application  

2. Choose Design > Extended Samples to start the Designer.  

3. A file selection dialog wil l appear. To start a new project, choose the New 
button.  

Note: This button is not available in Windows XP. Enter a name for the new 
print template in the "File name" field and then choose "Open".  
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To open or edit an existing project, choose Open. 

 
Figure 2.3: Open dialog  

4. The standard project for the respective project type is displayed. This standard 
project is normally an empty workspac e with a certain paper size and alignment.  
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Figure 2.4: Empty workspace  

With label projects, a certain label format (size and arrangement of  the individual 
labels on the sheet) is already specified as a default value.  

Note: A standard project  is a standard template for creating projects. However, 
you can change it to suit your needs and save it again under the na me 
"Default". 

5. If you have chosen "New project wizard" under Project > Options > Workspace 
the project wizard will start. The project wizard simplifies the job of creating new 
projects by leading you through different page setup options. But you will not be  
using the wizard for this example.  

2.3.1 Inserting a Company Logo Into the Report  

For the company logo, please use the "sunshine.gif" file, which you will find in the 
directory for the Sample Application. We also need a "Picture" object. Proceed as 
follows:  

1. In the "Objects" toolbar, choose the "Picture" object type.  

 
Figure 2.5: "Objects" toolbar 

Note:  Objects are your project's building blocks. They are generated in the 
workspace where they are also given a border with which their size and 
position can be changed. This border defines the space that the object takes 
up and thus also the maximum size to which the co ntents of the respective 
object can be expanded. Objects may overlap fully or partly.  

2. In the workspace, point the mouse to the position where the upper left corner of 
the object is to begin. The mouse cursor changes to a crosshair. Hold down the 
left mous e button and drag the crosshair to the lower right corner of the planned 
object. Release the mouse button when the object (the dashed border) is the 
right size. 

Note:  Objects can be added to the workspace in different ways: via the menu 
Objects > Insert , via the toolbar or via keyboard shortcuts, or with Drag & Drop  
from the list of variables.  

3. A file selection dialog will appear. Select the image file that you want.  

Note:  The following formats are available: WMF, EMF, BMP, DIB, PCX, SCR, 
TIFF, GIF, JPEG, PCD, PNG and ICO. As a general rule, you should use the RGB 
color space (not CYMK). List & Label itself supports transparency in PNG files 
by using the corresponding Windows functions. In our experience the majority 
of printer drivers do n ot support transparency so that reports with e.g. partly 
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transparent PNG files should thoroughly be tested on the actual hard -software 
combination. If that is not possible we recommend doing without the alpha 
channel.  

In addition, you can insert the pictu re into the project by enabling the (" Embed 
image in project file " checkbox option. This option copies the image to the 
project thus making it available even without the external file.  

4. After you select the file, the logo will be inserted.  

 
Figure 2.6: Report with picture object  

2.3.2 Adding a Title to the Report  

Use a text object to add a title to th e report. Text objects let you place text in the 
workspace. As well as fixed text, you can also insert the contents of fields (variables) 
from the database (e.g. company name), or you can use functions (page number, 
date etc.).  

1. In the "Objects" toolbar, choose the "Text" object type.  

 
Figure 2.7: "Objects" toolbar 

2. In the workspace, hold down the left mouse button and pull the object to the 
required size. 
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3. The formula wizard will now appear which you can use to define the contents of 
the text object.  

This dialog consists of a series of tabs each containing different elements to be 
edited. The following chapters explain the m eanings of these elements in more 
detail. 

Á Variables and Functions: the available variables, fields and functions.  

Á Condition: for defining IF -THEN-ELSE conditions. 

Á Text: for entering fixed text and tabs.  

Á Date Format: different date formats.  

Á Number Format: d ifferent number formats.  

Á Operators: available conjunction operators.  

You can also enter the expression that you want directly in the edit box or 
modify the text that is there (e.g. put something in brackets).  

Therefore, enter our title "List of products" d irectly. Fixed text must be enclosed 
in quotation marks. Enter names of variables and functions without brackets.  

 
Figure 2.8: Text in the formula wizard  

Note:  Please note that there are two ways of writing expressions, depending 
on their use. You will find more information about this in the chapter " Variables, 
Formulae and Expressions". 

4. The title will be displayed when  you close the dialog with OK.  
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5. Enlarge the letters by changing the font size in the mini toolbar that appears 
automatically.  

 
Figure 2.9: Formatting menu in mini toolbar  

6. You have now added the title:  

 
Figure 2.10: Report with text object  

2.3.3 Insert the Table for the Product List  

Use the "Report Container" object to add a table to the report. As the name says, a 
report container can hold several objects: tables, charts and crosstabs can be added 
in any order.  

Note:  The report container is not available in all applications. In app lications that 
don't have the report container, use the "Table" object.  

1. In the "Objects" toolbar, choose the "Report Container" object type.  

 
Figure 2.11: "Objects" toolbar 
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2. In the workspace, hold down the left mouse button and pull the object to the 
required size. 

3. A selection dialog will appear for the chosen object type. Choose the "Table" 
object type.  

 
Figure 2.12: Choosing the object type  

4. Now supply the data source in the following dialog. All available tables are 
shown hierarchicall y; in other words, under the tables, you will find the relational 
tables in each case. 

 
Figure 2.13: Choosing the data source 
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Select the "Products" table because it contains the fields that we want for our 
product list.  

5. A selection dialog will appear with all the fields in the "Products" table. In 
addition, underneath the "Products" table, you will also find the fields in the 
tables "Categories" and "Suppliers" which have a 1:1.relationship with "Products". 

 
Figure 2.14: Field selection dialog  

In this dialog , now choose the columns for the table. Double -click a field, e.g. 
"ProductName". The field will be added to the "Columns" area. 

6. Repeat this step for all fields that are to be shown in the table; i.e. also the 
"CategoryName" field from the linked table "Categories" and the "UnitPrice" field 
for the unit price. Confirm your selection with OK.  

7. The table will now be displayed in the workspace.  

Á The selected fields are displayed in the data line, in other words, the data line 
contains the data.  

Á In addition, a header line is automatically produced. Header lines are used 
mostly as column titles, i.e. the selected field names are now shown here as 
text. 

Á If you pull the report container widthwise to make it wider or narrower while 
holding down the CTRL key, the columns will be adjusted proportionally to fit.  

Á List & Label adjusts the width of the columns automatically. You can adjust 
the width of a column manually by moving the separating line to the right or 
the left with the mouse.  
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Note:  This changes all table columns, whose separators are within +/ -2 mm 
from the mouse position. If you hold down the CTRL key, the action will only 
be carried out for the line on which the mouse is positioned. If the "Column 
width modification affects next column" option is enabled (P roject > Options 
> Workspace), you can alter the column width while making the next 
column smaller.  

 
Figure 2.15: Report with table in th e report container object  

2.3.4 Formatting Table Fields  

Chapter "Creating Professional Tables" describes how you can format and modify a 
table. Only a few basic formatting options are explained here.  

1. In the product category column title , the field name "CategoryName" is shown. 
Click the respective field in order to change this text to "Category". The formula 
wizard will now appear, which you can use to change the contents of the field. 
Please consider that text must be enclosed in quotat ion marks. 
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Figure 2.16: Formula wizard with text input  

2. In addition, we want to format the unit price as currency and align the entire 
column to the right. You will find both formatting options in the mini toolbar that 
appears automatically. Click in the upper left corner to select the field containing 
the unit price.  

 
Figure 2.17: Selecting a single field  

3. Click the button for the formatting dialog  

 
Figure 2.18: Formatting a field directly  
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4. A selection dialog will now appear in which you can select the formatting that 
you want for the numeric field. To do this, choose the type on the left hand side 
i.e. "Currency". In the right pane, you can specify the curre ncy formatting in 
detail. The settings for the relevant application will be used in each case as 
standard. Alternatively, you can choose the system setting or a user defined 
setting.  

 
Figure 2.19: Formatting dialog  

5. Finally, select both fields (the header and the data line) to align them to the right. 
To do this, hold down the CTRL key and select both fields by clicking in the upper 
left corner in ea ch case. Then click the button for right alignment.  

 
Figure 2.20: Multiple field selection  

2.3.5 Displaying a Preview of the Report  

Until now, you have only seen the report in layout view as a structure with a record. 
To get an impression of the result, you can display a preview of the report. Use the 
tabs in the bottom margin of the workspace to change to the preview.  
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Note:  Real data preview mode is not supported by all applications.  

 

Figure 2.21: "Preview Options" toolbar 

The report will now be displayed with the data fr om the "Products" table. You can 
also change the number of "products" or data records in the Sample Application.  

1. To do this, save the report with File > Save.  

2. End the Designer with File > Close.  

3. In the Sample Application, choose Options > Settings and incr ease the 
maximum number of root records to 50.  

4. Open the print template that you created again via Design > Extended Samples, 
and switch to preview mode. Your report will look roughly like this:  

 
Figure 2.22: Real data preview 

2.3.6 Adding a Page Number  

It's a good idea to add a page number in the lower area of the page. To do this, add a 
new tex t object. You will be using functions (such as the page number function) as 
well as fixed text with this object.  
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1. In the "Objects" toolbar, choose the "Text" object type.  

 
Figure 2.23: "Objects" toolbar 

2. In the workspace, hold down the left mouse button and pull the object to the 
required size. 

3. The formula wizard will now appear which you can use to define the contents of 
the text object. The available functions are shown in the right pane. You can use 
an auto filter with this list. Type "page" in the filter field. This will cause all 
functions containing the expression "page" to be displayed.  

Á The "Page$ ()" function returns the page number.  

Á The "TotalPage$ ()" function returns the total number of pages.  

Add the "Page$ ()" function to the result area by double -clicking.  

4. If you now want to output a footer in the form of "Page 1 of 2", you can enter the 
text "of" directly in the  usual way. Please consider that individual parts must be 
joined with a "+" and that text must be enclosed in quotation marks.  

5. Now add the "TotalPages$ ()" function by double-clicking to get the total number 
pages. The formula will look like this:  

 
Figure 2.24: Formula wizard with functions and text  

6. You can center this line in the report in the usual way:  
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Figure 2.25: Quick format "centered" alignment  

7. Switch to preview mode to view the result:  

 
Figure 2.26: Real data preview in the Designer  

2.3.7 Print or Export the Report  

You can start the print function directly from the higher -level program, from the real 
data preview or via File > Print/Export .  

1. Choose File > Print/Export.  

2. The Print Options dialog will appear.  

Á Under "Print target ", you can change the printer or the printer configuration.  

Á Select the output format (e.g. preview, printer, Excel) under " Direct t o".  
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Figure 2.27: Output options  

3. If you have selected an export format (such as PDF), choose the storage location 
in the following "Save As" dialog and enter a name for the file to be created in the 
"File name" field.  

 
Figure 2.28: Save dialog when exporting to a dif ferent format  
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2.4 Producing a Simple Invoice  
In this chapter, you will now meet functions and possibilities for designing reports.  

For the next example, you will create a multi -page invoice with covering letter, 
invoice header, totals, f ooters, enclosure and printed copy.  

2.4.1 Create a New Print Template  

1. Start the combit List & Label Sample Application (see Chapter " The Sample 
Application ").  

2. Choose Design > Invoice to start the Designer.  

3. A file selection dialog will appear. To start a new project, choose the New 
button.  

Note: This button is not available in Windows XP. Enter a name for the new 
print template in the "File name" field and then choose "Open".  

To open or edit an existing project, choose Open. 

2.4.2 Adding a Co mpany Logo  

Use the picture object to add a logo.  

1. In the "Objects" toolbar, choose the "Picture" object type.  

 
Figure 2.29: "Objects" toolbar 

2. Pull the object to the right size and select an image file (see Chapter " Inserting a 
Company Logo Into the Report "). 

2.4.3 Add the Address Field  

To add an address, use the text object. Text objects le t you place text or the contents 
of fields in the workspace.  

 
Figure 2.30: Address field: it should look like this.  

1. In the "Objects" toolbar, choose the "Text" object type.  

 
Figure 2.31: "Objects" toolbar 
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2. Pull the object to the required size.  

3. The formula wizard will now appear which you can use to define the contents of 
the text object.  

This dialog consists of a series of tabs. On the "Variables and Functions" tab, 
select the variable for the company address (company) from the list of available 
variables and fields.  

You will see an auto filter field above the list of variables. This means that you 
can enter "Company" to display all fields and variables containing this expression. 
Select the variable that you want by double -clicking and confirm your selec tion 
with OK. You have now defined the first line of the address field.  

 
Figure 2.32: Formula wizard with variable  

4. A text object can hold a s many paragraphs as you want and they can all have 
completely different display properties. You can add more paragraphs by means 
of the mini toolbar which appears automatically. Choose "Append paragraph" to 
define an additional line.  
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Figure 2.33: Adding another paragraph via the mini toolbar  

5. The formula wizard will now appear, which you can use to define the contents of 
the paragraph. Now enter the first name and the last name of the recipient. First 
choose the "Firstname" variable. 

6. You should insert a space before choosing the "Lastname" variable to prevent 
the contents of the two variables from being placed end to end. A space is 
simply "Text". Fixed text must be enclosed in quotation marks. So now enter "+" 
as a joining operator followed by " " for the space.  

7. Now select the "Lastname" variable. You must naturally also join this with "+". 
The whole line looks like this:  

 
Figure 2.34: Linking variables and text 

8. Now continue with the other variables: street and city. You have now completed 
the address field.  

 
Figure 2.35: Text field with 4 paragraphs 

2.4.4 Create Invoice Header With Number and Date  

Use the text object again to add the text "Invoice", the invoic e date and the invoice 
number to an invoice header.  
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Figure 2.36: Invoice header: it should look like this.  

1. In the "Objects" toolbar, choose the "Text" object type.  

2. Pull the object to the required size.  

3. The formula wizard will now appear, which you can use to define the contents of 
the text object. Type "Invoice".  

4. Add another paragraph by means of the mini toolbar that appears automatic ally 
and the "Append paragraph" (insert) button. 

5. The formula wizard will appear. Type "Invoice date". 

6. Before you enter the invoice date, insert a tab stop so that the invoice date is 
aligned to the right. You can insert a tab stop by means of the "Text" ta b.  

 
Figure 2.37: Adding a tab stop to a text expression 

7. You create a tab stop with the "Tab" button and you define the position and 
alignment with the "Properties" button.  
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Note:  Only one tab stop can be inserted on each line. A tab stop causes the 
preceding text to run only as far as the tab stop. A tab stop that is right aligned 
will cause the text that follows it to be justified to the ri ght. The distance from 
the left margin determines the position of the tab stop.  

Since a tab stop is also a character, it must also be enclosed in quotation marks. 
Alternatively, in this example, you can insert the tab stop with "Insert" to the 
existing "Invoice date" text. 

8. Finally, position the cursor outside of the text field and insert the "Invoice_Date" 
variable with the "Variables and Functions" tab.  

The format will be converted automatically.  

Conversion with the "Date$()" function is essential since t he invoice date has the 
"date" type and the value that is returned is already defined as a "string" by the 
"Invoice date" text expression entered earlier. The return value must always be 
unique. The date value must therefore be converted to a string by mea ns of a 
function. The "Date$()" function is one way of doing this.  

 

Figure 2.38: Format conversion with Date$()  

The automatic format conve rsion uses "%x" as the formatting parameter. If you 
want a different output format, switch to the "Date Format" tab. You can choose 
a format here and then select the "Invoice_Date" variable. 
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9. Now add the invoice number in the same way.  

The format will be co nverted automatically here as well.  

 
Figure 2.39: Format conversion with Str$() 

Conversion with the "Str$()" function is essential since th e invoice number is a 
field with the "number" type and the value that is returned is already defined as a 
"string" by the "Invoice number" text expression entered earlier. The return value 
must always be unique. The number must therefore be converted to a string by 
means of a function. The "Str$()" function is one way of doing this. This function 
has 3 parameters: The first parameter is the number that is to be converted to a 
string; the second parameter specifies the minimum length and the third 
parameter the number of decimal places.  

10. Now increase the font size for "Invoice". To do this, select the relevant line.  

11. Set the font size to 28 by means of the "font size" button in the mini toolbar that 
appears automatically.  

12. Now increase the distance to the next l ine, i.e. open the paragraph properties 
dialog via the "Object properties" button in the mini toolbar. In this dialog, you 
can define the properties for each line. Set the value for the "Paragraph Spacing" 
property for the first line to 12  pt. 

 
Figure 2.40: Paragraph properties dialog 

13. And you now have an attractive invoice header:  
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Figure 2.41: Invoice header  

2.4.5 Adding the Item List  

Use the "Report Container" object to add the item list to the report. As the name 
says, a report container can hold several objects: tables  and freely defined content, 
charts and cross tabulations. You need the "Table" element for the item list, and "Free 
content" for the covering letter. Please see chapter " Insert the Table for the Product 
List" for an introduction about how to create tables.  

1. In the "Objects" toolbar, choose the "Report Container" object type.  

 
Figure 2.42: "Objects" toolbar 

2. In the workspace, hold down the left mouse button and pull the object to the 
required size. 

3. A selection dialog will appear for the chosen object type. Choose the "Table" 
object type.  

 
Figure 2.43: Object type selection  
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4. Now select the data source in the following dialog. All available tables are shown 
hierarchically; in other words, under the tables, you will find the related ta bles in 
each case. 

Select the "Items" table because it contains the fields that we want for our item 
list.  

5. A selection dialog will appear with all the fields in the "Items" table.  

6. In this dialog, now choose the columns for the item list. Double -click one after 
another on the fields: "Quantity", "No", "Description1", "UnitPrice". This will add 
the fields to the "Columns" area. Confirm your selection with OK.  

 
Figure 2.44: Field selection dialog  

7. The table will now be displayed in the workspace. A header line with strings as 
the column titles and a data line with the contents of the fields will be created 
automatically.  

List & Label adjusts the width of the columns automatically. You can adjust the 
width of a column manually by moving the separating line to the right or the left 
with the mouse.  

Note:  This changes all table columns, whose separators are within +/ -2 mm 
from the mouse  position. If you hold down the CTRL key, the action will only be 
carried out for the line on which the mouse is positioned. The "Column width 
modification affects next column" option (Project > Options > Workspace), lets 
you alter the column width while m aking the next column smaller.  
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Figure 2.45: Changing column widths with the mouse  

8. In the next step, you add a new column: "Total". Select the "UnitPrice" field by 
clicking in the upper left corner of the field. Then choose the "Append column" 
button in the mini toolbar.  

 
Figure 2.46: Select column  
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9. A menu will appear for the selected field type. Choose "Text" here.  

10. The formula wizard will now appear, which you can use to define the contents of 
the field. Type "Total" and confirm with OK.  

A message will now appear gi ving you the option of reducing the width of the 
columns to allow the new column to be inserted in the visible area. Confirm this 
dialog. You have now added an additional column to the header line. You now 
need this column in the data line as well.  

11. Now select the data line field containing the item price and add a new column to 
it.  

 
Figure 2.47: Add a new column  

The total price is now to be calculated here. The total price is calculated by 
entering "Quantity*ItemPrice". To do this, select the relevant variables by double -
clicking them.  

 

Figure 2.48: Multiplying two values in the formula wizard  
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Note:  Open the list of available operators by clicking the "Operators" tab. 
Operators join two or more values or variables to give a new value. In this way, 
you can formulate arithm etic expressions (basic arithmetic operations) or 
logical expression. You can combine multiple operations in one expression. 
Please consider the calculation hierarchy of the operators used and place them 
in brackets if necessary. The "+" operator has a spe cial meaning. It is not only 
suitable for additions ("Number" and "Date" value types) but is also used for 
joining strings.  

2.4.6 Alignment and Formatting  

Make use of the numerous formatting options to present the invoice in the form that 
you want. For example, change the column title and format the amounts as currency.  

1. Click the column title that you want to change. The formula wizard will now 
appear, which you can use to change the contents of the field. Please consider 
that text must be enclosed in quotation marks. 

2. In addition, you should also align the columns for the unit price and the total 
price with the column titles. To do this, hold down the SHIFT key and select all 4 
fields by clicking in the upper left corner of the "Item Price" data line. Then 
choose the button for right alignment in the mini toolbar.  

3. To format both amounts as currency, hold down the CTRL key and select both 
fields by clicking in the upper left corner of each one. Then choose the button 
for the formatting dialog.  

 
Figure 2.49: Multiple field selection  

4. A selection dialog will now appear in which you can select the formatting that 
you want for the numeric field. To do this, choose the type on the left hand side 
i.e. "Currency". In the right pane, you can specify the currency formatting in 
detail. The settings for the relevant application will be used in each case as 
standard. Alternatively, you can choose the system setting or a user defined 
setting.  
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Figure 2.50: Formatting a field  

5. Format the field for the quantity as a number without decimal points.  

6. Our item list will now look roughly like this:  

 
Figure 2.51: Preview  

2.4.7 Background Color and Frame  

In order to structure the invoice and make it  more attractive, it's a good idea to give 
at least the column headers a colored background. You can also modify the 
background color.  

1. To do this, select a column title.  

2. Now open the paragraph properties dialog via the "Object properties" button in 
the min i toolbar. In this dialog, you can define the properties for each column 
and row. Hold down the CTRL key and select all columns.  
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3. Click the "+" sign to expand the "Background" property group.  

4. For the background, choose the "Pattern/block color" property and  the color, e.g. 
LL.Color.LightSkyBlue. You reach the LL.Colors via the arrow button and the 
standard color dialog via the ... button.  

 
Figure 2.52: Object properties dialog for the table: background  

5. In addition, you want to increase the spacing between the header and the data 
line. Since this is a line property (and not a column property), select the line.  

Here you have the "Spacing" property. Choose e.g. 0.1 inch as "Bottom" to 
increase the spacing below the column title.  
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Figure 2.53: Object properties dia log for the table: margins  

6. Now it only remains to make the settings for the frame. You can define different 
settings independently for each cell. However, it's normally a good idea to make 
the settings for the entire table. For this reason, the settings fo r the frame are 
included in the table properties. You will find the table properties, as standard, 
on the lower left when you select the table in the "Report Container" tool 
window. When you select the property, there is a button which you can use to 
open the dialog for the frame properties.  
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Figure 2.54: Frame properties  

7. Choose "white" as the color and click "Outline" to apply the color.  

Please note: If you don't apply the setting but simply confirm the dialog with OK, 
your settings will be lost!  

8. The invoice will now look roughly like this in the preview:  

 
Figure 2.55: Preview (frame and background)  
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2.4.8 Invoice Footer With Totals  

You now need to output the net totals, the VAT and the total amount in the invoice 
footer. You can simply insert these values if they are held as  fields in the database.  

In our case, however, you must first calculate the values. To do this, you use the 
"Sum()" aggregate function. This function totals the values that are passed to it.  

Since the totals are to be output at the end of the table, you de fine a footer for this 
purpose. 

1. Click the "Append Line" button in the mini toolbar and then click "Footer".  

 
Figure 2.56: Add new lin e 

2. You have not yet defined a line for this line type so you will be asked whether 
you want to use an existing line definition from one of the other line types. This 
wouldn't save any time at this point. Therefore, choose the "Single field or free 
content" option.  

 
Figure 2.57: Applying a line definition  
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3. The formula wizard will open to allow you to define the contents of the f irst 
column. Enter "Subtotal", not forgetting to enclose it in quotation marks.  

4. Once you have created the first line, add another column to it for the 
aggregation. Use the "Sum()" function for aggregating values. You can either type 
it in directly in the r esult field in the formula wizard or you can select the function 
from the list of aggregate functions by double -clicking. As a parameter, enter the 
value to be aggregated ð in this case Quantity*ItemPrice.  

 
Figure 2.58: Totaling with Sum() 

5. The entire line should now be moved a little to the right. Hold down the CTRL key 
and drag the column separator on the extreme left at the outer edge of the table 
to the right. An empty column will be inserted automatically as a spacer on the 
extreme left.  

6. You must also format the total field as currency, give both columns the same 
background color as the header line and set the "Top" margin to 0.1 inch to  
correspond with the "Bottom" margin of the header line.  

7. As these footers are only to be output on the last page, even in the case of 
multiple page invoices, you must now specify the "Lastpage()" or 
"LastFooterThisTable()" function for the "Appearance Condition" line property.  
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Figure 2.59: Object dialog with 3 columns  

8. You have now defined the first footer and the invoice looks like this:  

 
Figure 2.60: Preview (footer)  
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2.4.9 Create Additional Footer Lines  

You can create as many line definitions as required for each line  type (data line, 
footer). The different line definitions are shown in the object dialog as a tree 
structure.  

For our example, now create two more footers for the VAT and the grand total.  

 
Figure 2.61: Preview 3 footers  

1. To add more lines in the object dialog, first select an existing line definition. You 
can then create a new line definition with the "Append line definition" button.  

 

 
Figure 2.62: Object dialog with 3 columns  

Alternatively, you can add a new line in the workspace via the context menu or  
with the mini toolbar.  

2. A dialog will appear asking you whether you want to use an existing line 
definition. It saves some time if you use the footer that you have already created 
as you will not have to configure the left margin, alignment or background 
colors. Therefore, choose the "Line definition 1" entry from the "Footer" area.  
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3. The line will now be inserted. Click the "Subtotal" field so that you can then 
change the content to "VAT 19%" with the formula wizard. Don't forget to 
enclose the text in quota tion marks.  

4. Once you have created the column, click in the column to enter the aggregation. 
Instead of the total net amount, the 19% VAT is to be output here. Therefore, 
you simply multiply the amount by 0.19.  

Sum(Item.Quantity * Item.UnitPrice * 0.19)  

5. Proceed in the same way with the third footer. Copy the existing footer, change 
the content and, in the formula, add the VAT to the total, like this:  

Sum(Item.Quantity * Item.UnitPrice * 1.19)  

6. You have now defined the first footer and the invoice looks like t his:  

 
Figure 2.63: Invoice with 3 footers  
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2.5 Creating a Simple Label  
For your first label, you will now create an item label.  

1. Start the combit List & Label Sample Application  

2. Choose Design > Item Labels to start the Designer.  

3. A file selection dialog will appear. To start a new project, choose the New 
button.  

Note: This button is not available in Windows XP. Enter a name for the new 
print template in the "File name" field and then choose "Open".  

To open or edit an existing project, choose Open. 

4. The standard project for this project type is displayed. This standard project is 
normally an empty workspace with a certain paper size and alignme nt.  

5. Select a label format via Project > Page Setup. In the "Templates" tab, choose 
the template that you want from the predefined label formats of various 
manufacturers. This specifies automatically the size of the individual labels, how 
many are to appear on the sheet and how they are to be distributed. You will 
find more information about this in the chapter " Templates for Label Formats ". 

 
Figure 2.64: Specify label format  










































































































































































































































































































































































































































































































































































