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1. Introduction

With the List & Label Designer, you create or edit different print templates for

printing information that originates either from a database or another data source. In

the Designer, you then have all the data at your disposal and can prepare it for
printing in different way s.

The Designer always uses the data that is passed from the program, in other words,

the application handles the process of selecting and compiling the data.

Thus, "the Designer"” is not a self-contained application, but rather is incorporated in
List & Label as an inherent part of an application.

The Designer 2the print, preview and export dialog 2 is normally started via a menu
item (e.g. Configuration > Print or Output > Print).

1.1 General

The different print templates are re ferred to as "Projects”. Along with the actual print
information, a project also contains, above all, layout specifications such as page size
and orientation, fonts, colors, frames, circles, lines, graphics etc. The List & Label
Designer can handle three different types of projects: Lists, labels and cards.

The individual elements of such a project are called "objects". For example, a project
can contain text objects, picture objects and a report container.

The required objects are normally selected in the object list, created on the
workspace with the mouse and then given the respective contents and layout
properties.

The List & Label Designer provides different types of objects which you can position
freely in the workspace and change the size as required.

Text and contents of variables

Lines

b
O Rectangles
o Circles and ellipses

@ Picture object

|||||| Barcode
242

Report container or Table object (depending on the application): The Report
container can hold tables, charts and crosstabs.




Introduction

Charts. Schematic view of data.

ﬂ: Crosstabs. For presenting data in multiple dimensions.

Formatted text. For changing the formatting within a line.

Form elements. For entering data in the preview and PDF forma t.

g2

Gauge

%
e

HTML content

&

OLE container. For linking OLE documents (e.g. Word, Excel).

L

Form templates are placed in the background of the workspace as a template so
that other objects can be aligned to them. Form templates are not included when
printing.

k|

1.2 Screen

The Designer interface consists of a workspace and different tool windows.

f
f

You add objects by means of the ' Objects' toolbar.

The objects are placed in the workspace. You change the shape and size of the
workspace via Project > Page Setup .

You can select the viewing mode by means of the tabs in the bottom m argin of
the workspace: Layout, Layout Preview, Preview.

The status bar with the current mouse position, the current operation and the
position/size.

The variable list displays all variables which are available in the current project;
for list projects, al | available fields are also displayed.

The layer list shows the different display layers.

The hierarchical object list shows all objects in the order in which they will later
be printed.

The '"Report Structure" shows all elements belonging to a report co ntainer in the
order in which they will later be printed.

The properties of the selected objects or project are displayed in the properties
tool window.
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The Sample Application

2. Getting Started

This chapter describes how to create a simple list based on the combit List & Label
Sample Application .

If you use List & Label as part of an application, you can usually start the Designer via
a menu item or similar. The functionality can differ slightly from the description
below.

2.1 The Sample Application

The Designer is not available as a self-contained application, but rather is
incorporated in List & Label as an inherent part of an application. For this reason, the
Sample Application is used to create the examples.

You will find the Sample Application in the program menu of the List & Label
installation. Alternatively, you can download it as part of the combit List & Label
program installation at www.combit.net/en/reporting/ .

You can then start the Designer via the "Design" menu item. Start the print, preview
and export dialog via the "Print" menu item. Under options, you will find various
configuration settings such as the language of the program interface or the number
of sample files.

List & Label Sample Application = e
File Design Print Web Options 2

Welcome to the List & Label Sample Application!

ou'll find different ternplates showcasing the features of List & Label. Just click on the links below to quickly
navigate to the topic of interest.

AR

as®

325

aB®

Extended
Labels Reports Barcodes samples Invoice Mail Merge  Form

Desian Desian Design Design Design Desian Design
Print Print Print Print Print Print Print

Wersion 16.0.0.0 @ combit GmbH

Figure 2.1: Sample Application
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Getting Started

2.2 The Sample Database

The List & Label Sample Application contains a Microsoft Access Database for a
fictitious company called "Northwind" with sample data for a food wholesaler.

It is a relational database meaning that the data is distributed across several tables.
Each table contains data elements that are related to one ano ther. For instance, one
table contains the product data. Another contains the product categories. A table's
columns are referred to as fields (product name), and the rows of a table as data
records.

g - =2 X
=
Suppliers L | Products Order Details Braee Customers E
% Suppliedd ? Producti g ? Ordenn ©Ll § ardemd L0 9 customenD
CompanyName L Producttlame ? PraductiD Custamend CompanyHame
Contacthlame Suppliero UnitPrice = EmployeslD ContactMame
ContactTitle CategordD Quantity OrderDate ContactTitle
Address QuantityPerlnit Discount RequiredDate Address
City UnitPrice ShippedDate City
Region UnitsInstock Ship¥ia Regian
PastalCade UnitsOnOrcer Employees Freight PostalCode
Country Rearderl evel % Employed Shiphlame Cauntry
Phaone Discontinued LastHame ShipAddress Phone
Fax Firstilame ShipCity Fax
HomePage Title shipRegion
TitleOfCourtesy ShipPostalCade -
T BirthDate ShipCountry . hippers
5 1 HireDate ? ShipparD
7 ca Y Address CompanyMame
Categaryhlame City Phone
Desaription Region
Ficture PastalCode
Country
HomePhone
Extension
Photo
Notes
ReportsTo
-
A fuu] »

Figure 2.2: Structure of the Microsoft Northwind sample database

2.3 Produce a Simple Report

For a first simple report, you will produce a prod uct list in alphabetical order with a
report title and a company logo.

1. Start the combit List & Label Sample Application
2. Choose Design > Extended Samples to start the Designer.

3. A file selection dialog will appear. To start a new project, choose the New
button.

Note: This button is not available in Windows XP. Enter a name for the new
print template in the "File name" field and then choose "Open".
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Produce a Simple Report

To open or edit an existing project, choose Open.

[L] Open E

.« combit ¥ LLLG » Sample Application »

Organize ¥ New folder =~ 0 @
S Favorites A Name Date taken Tags Size Rating
(5 Recently Change ) kB,
1! Public Lo ¥ %F v
B Desltop 1! drilldown reports KRk
18 Downloads 1 pictures gk Bk ok 4
%l Recent Places || Chart in table.stt MKB WWWWYT
g __| Chart with rows.srt UKB W WL
4 Libraries || Crosstab and chart.... TIKE Yy erivy
[ Documents || Crosstab.srt 84KB TFITIPITT
o Music | Different chart type... 62KB
&= Pictures || Drilldown report wit... 55 KB
B8 Videos | Include.srt SKE
L Miked portrait andl... 19 KB
18 Computer || MySaple.srt KB
&, Local Disk (C3) || Subreports and rela.. 203 KE
& CDDrive(B)  ~ 4 m |
Description
File name: + | Extended sample (51t} -
[ hew !}J [ open |+ [ conet |

B |

Figure 2.3: Open dialog

The standard project for the respective project type is displayed. This standard
project is normally an empty workspace with a certain paper siz e and alignment.

File Edit Project Objects View ?
iDoee|d44|smm|9|wm aan|o®|(S S| iy @28
Objects [x| ] 10 2.0 30 40 5 6.0 7.0 8.0 il | [Vanables [x]
T L e L e e R R R R IRy frat
[} Project b= -
QU S a3 Variables
= N =1
B [ Project variables
& = 4 (5D Fields
S P
- = 1) Categaries
< = 153 Customers
= g b0 Employess
Objects [Report Str..| Layers | Preview ||| = &) Order_Details
LI} g .
" [Properti x| 72 52 Orders
lop;ltlles 5 : b {2 Products
[EE &) o E b A Sales
=] General Settings = £ Shippers
Praject Description List 2 Label Project File 5 b2 Suppliers
Active Design Layout ==
Humber of Issues 1 =
Embed Drilldown Repo... Ho S
Minimum Page Count L ~Z
Transition Effect for Sli.. E
Mail Parameter 2=
Fax Parameter =
==
General Settings M
B Layout =4 Layout Preview |~ Preview
5410,0317  Select -nathing selected-

Figure 2.4: Empty workspace
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Getting Started

With label projects, a certain label format (size and arrangement of the individual
labels on the sheet) is already specified as a default value.

Note: A standard project is a standard template for creating projects. However,
you can change it to suit your needs and save it again under the name
"Default".

5. If you have chosen "New project wizard" under Project > Options > Workspace
the project wizard will start. The project wizard simplifies the job of creating new
projects by leading you through different page setup options. Buty ou will not be
using the wizard for this example.

2.3.1 Inserting a Company Logo Into the Report

For the company logo, please use the "sunshine.gif" file, which you will find in the
directory for the Sample Application. We also need a "Picture" object. Proceed as
follows:

1. Inthe "Objects" toolbar, choose the "Picture" object type.
HalANooR@NAEL9BM
Figure 2.5: "Objects" toolbar

Note: Objects are your project's building blocks. They are generated in the
workspace where they are also given a border with which their size and
position can be changed. This border defines the space that the object takes
up and thus also the maximum size to which the contents of the respective
object can be expanded. Objects may overlap fully or partly.

2. In the workspace, point the mouse to the position where the upper left corner of
the object is to begin. The mouse cursor changes to a crosshair. Hold down the
left mouse button and drag the crosshair to the lower right corner of the planned
object. Release the mouse button when the object (the dashed border) is the
right size.

Note: Objects can be added to the workspace in different wa ys: via the menu
Objects > Insert , via the toolbar or via keyboard shortcuts, or with Drag & Drop
from the list of variables.

3. Afile selection dialog will appear. Select the image file that you want.

Note: The following formats are avail able: WMF, EMF, BMP, DIB, PCX, SCR,
TIFF, GIF, JPEG, PCD, PNG and ICO. As a general rule, you should use the RGB
color space (not CYMK). List & Label itself supports transparency in PNG files
by using the corresponding Windows functions. In our experience the majority
of printer drivers do not support transparency so that reports with e.g. partly
transparent PNG files should thoroughly be tested on the actual hard -software
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combination. If that is not possible we recommend doing without the alpha

channel.

In addition, you can insert the picture into the project by enabling the (* Embed
image in project file " checkbox option. This option copies the image to the
project thus making it available even without the external file.

4. After you select the file, the logo will be inserted.

[LL] Designer - C:\Program Files\combit\LL16\Sample Appli

7023, 1374 Seleet
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Relative Path Ho
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Keep Prapartions  Ves
Alignment Centered
Design
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Figure 2.6: Report with pict ure object

2.3.2 Adding a Title to the Report

Use a text object to add a title to the report. Text objects let you place text in the
workspace. As well as fixed text, you can also insert the contents of fields (variables)
from the database (e.g. company name), or you can use functions (page number,

date etc.).

1. Inthe "Objects" toolbar, choose the "Text" object type.

.\DQBI

Figure 2.7: "Objects" toolbar

required size.

the text object.

Py b
i & e e

In the workspace, hold down the left mouse button and pull the object to the

The formula wizard will now appear which you can use to define the contents of



Getting Started

This dialog consists of a series of tabs each containing different elements to be
edited. The following chapters explain the meanings of these elements in more
detail.

f Variables and Functions: the available variables, fields and functions.

f Condition: for defining IF -THEN-ELSE conditions.

f Text: for entering fixed text and tabs.

f Date Format: different date formats.

f Number Format: different number formats.

f Operators: available conjunction operators.

You can also enter the expression that you want directly in the edit box or
modify the text that is there (e.g. put something in brackets).

Therefore, enter our title " List of products " directly. Fixed text must be enclosed
in quotation marks. Enter names of variables and functions without brackets.

Edit Text =

Variables and Functions | Conditian | Text | Date Format | Number Farmat | Operatars

~ Functions:

. I3 Variables -
[ Project variables

3 Numerical functions
> IL2) Mathematical functions
& I[3) Date functions

| Sting functians

{5 Misc. functions

» [23) Aggregate functians
{5 Barcode functions il

Insert

“List of products” (-
= 0
< ’
ﬁ List of praducts
-y
=y ok | [ cancel

Figure 2.8: Text in the formula wizard

Note: Please note that there are two ways of writing expressions, depending
on their use. You will find more information about this in the chapter " Variables,

Formulae and Expressions".

4. The title will be displayed when you close the dialog with OK.

5. Enlarge the letters by changing the font size in the mini toolbar that appears
automatically .
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Aral v 36 B 5r U F

B X | @ J

ist of products ég’éﬁ'éy'

Figure 2.9: Formatting menu in mini toolbar

6. You have now added the title:

Figure 2.10: Report with text object

2.3.3 Insert the Table for the Product List

Use the "Report Container" object to add a table to the report. As the name says, a
report container can hold several objects: tables, charts and crosstabs can be added
in any order.

Note: The report container is not available in all applications. In applications that
don't have the report container, use the "Table" object.

1. Inthe "Objects" toolbar, choose the "Report Container" object type.

Figure 2.11: "Objects" toolbar
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